Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!


mSecure Cloud sync fails - error message 3840

mSecure 6.1.5. (999) fails to sync on Mac (M2 Mac Mini, Sonoma).

mSecure Error message:  "There was an error saving data to the mSecure Cloud.  The data couldn't be read because it isn't in the correct format. (3840)" 

What does this mean and how do I resolve it?

Hi Frank,

Thank you for contacting us, and I'm sorry for the issue you are experiencing. I'm not sure what's happening here, but we'll get it fixed. We had a server outage not too long ago that caused errors like this to get displayed when the app attempted to sync. However, that outage has since been fixed, and we have not experienced any other server issues since. 

Real quick, do you have mSecure installed on any other devices, and if you do, is all your data synced over to at least on of those devices?

One other question, if you have your data in mSecure on a different device, are you seeing the same message when you open the app and it attempts to sync?

In answer to your questions...

Yes, I have mSecure installed on other devices (iPhones, iPad, laptop).

No, my most recent changes (on the Mac) have not synced successfully to the other devices.

No, none of the other devices show an error when they sync.

Hi Frank,

Ok, I'm going to have you create a backup really quick in mSecure on your Mac. After that, I'll have you delete your database file and then sign back in to your account. My hopes are that resetting the database file will take care the error message, and if so, you can then restore from the backup you created. 

First, to create a bakcup:

1. Open mSecure on your Mac

2. Click "File > Backup" in the menu bar at the top left of your screen

3. Save the backup on your desktop

Next, to reset the database file on your Mac:

1. Open mSecure on your Mac, and look in the top left corner of your screen. You should see "mSecure" in the menu bar. To the right of "mSecure," you should see the word "Help." You'll click on that in step #2 below.

2. Click Help in the menu bar at the top left of your screen. A contextual menu will appear. Hold down the "option" key on your keyboard, and you should see two hidden options appear at the bottom of the contextual menu.

3. Click "Show Data File in Finder", and a Finder window will appear revealing mSecure's database file, which is named, "mSecure.mscb"

4. Close mSecure

5. Move the "mSecure.mscb" file to the trash

Now you have reset the Mac app, and you're ready to sign back in to your mSecure account:

1. Open mSecure on your Mac if it is closed

2. Skip the welcome screens to go directly to the Sign Up / Sign In screen

3. Click "Sign In"

Enter your mSecure account's email address for the username, then enter the password for that account to sign in to it.

Before you restore from the backup file, is everything working now? Does the sync complete without any errors?

That worked. Problem solved. Thanks, Mike.

Do you have any idea what caused the error?

That's great to hear Frank. Unfortunately, I don't know what could have caused the error you were seeing. The only thing I can think of is that we had a server outage a couple weeks ago, and it's possible some local data got out of sync with the server. If that happened, the error message you were seeing is not accurately describing what the problem is. Sometimes that happens where the app has a default message to display when it encounters something it can't work through. The error is handled, but the message getting displayed could be wrong.

I don't foresee you running into this again, but if you do, please let me know, especially if it starts to happen frequently. This is not something you should have to be working around, so we would need to figure out what's causing the problem.

Anmelden oder Registrieren um einen Kommentar zu veröffentlichen