Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!


Cannot Access My MSecure Account with New iPhone Update

Hello, I have an order version of MSecure (4.0 or older) on my iphone only (and no where else). After the latest iPhone update, I am no longer able to open my MSecure app to access all of my crucial information. I followed the instructions I found online and downloaded the latest MSecure app, created a new account, and tried to import the data from the older version over. The problem is I was accessing the old MSecure using Face ID so I don’t remember the password. I tried every combination possible but was not successful. Can you please please help me? I am panicking!!! What can I do access my important data from the old MSecure account? I would greatly appreciate your help in the matter.

Hi Trang,

Thank you for contacting us, and I'm sorry for the issue you are experiencing. The only thing we can do here is have you try installing a utility build of mSecure 4 to see if that will make it so you can retrieve your password. If you can, then you'll be able to use it to import your data into mSecure 6.

In order to do that, I'll need to get the email you use for your Apple ID, so you can download the utility app from TestFlight. Please send me an email at "" After you send it, respond here and I'll get back to you with further instructions.

Hi Mike, Thank you for your reply. I had emailed my Apple ID to this morning. The person who I responded to was Liam Thropp. I don’t know if I should wait to hear back from him or work with you. Thanks.

Hi Trang,

I just found your email and responded to it. We'll keep our correspondence via email from here on out.

Anmelden oder Registrieren um einen Kommentar zu veröffentlichen