Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!


upgrading msecure 5 to 6: missing custom icons


Can anyone help with this annoying bug?

1. about 10% of the icons in my msecure5 records were 'hand imported',  i.e. I could not find corresponding icons to import using  the msecure cloud-search tool,  so I imported custom  .PNG images that did the trick...

2. ...but when I upgraded to msecure6, many of those custom  icons disappeared. I guess some slightly different rules in msecure 5 and 6 for the acceptable icon formats.

Any workaround to that???


John   (running msecure on Windows 10 in Virtualbox, as there is still no Linux version    ;-(

Hi John,

Thank you for contacting us, and I'm sorry for the issue you are experiencing. I'm not sure what has happened here, but all your custom icons should have imported correctly moving from v5 to v6. Real quick, when you edit a record, do you see the icons that you believe to be missing after clicking the pencil over the records icon and then clicking the "Custom" tab?

Also, do you happen to have a backup made in mSecure 5 from before you upgraded to mSecure 6? With the new restore feature, you can restore data from a backup and choose not to replace the current data. Instead, newer data in the app will be retained after the restore.

Thanks for your help Mike.

Well, it's even queerer than I thought...

1. In fact, on my old Samsung Android 7 tablet running msecure 6.06.1626  the icons appear just fine. So do they in msecure running in Windows 10 in Virtualbox on my Linux PC.

 It is just on my Samsung Android 11 phone that 6.06.1626 that the 'custom' icons (which showed up OK in msecure5) do not appear, rather an encircled query (?) is shown for the icon.

2. If,  as you suggest, I go 'find' again the custom icons and edit a record, the icon appears in the updated record while it is still in edit mode, but when I save that record, the icon disappears again.

If this is just me with this problem then forget it, but maybe you have other (Samsung??) users with this bug? Obviously I use msecure far more often with my Android 11 phone than with my old Android 7 tablet!



Thank you for the follow-up on this John. I'm still not sure what's happening, but I'm hopeful we can get everything resolved so that you're seeing the right icons on your records on all your devices. Since I haven't seen this before on my device or with other customers in support, I think the best thing to do is simply reinstall mSecure on your phone. If you do that, all of your data should be synced in fresh from your PC, and I'm hopeful that will take care of the problem. If it doesn't, I'll need to talk to our developer about this, because what you're experiencing should obviously not be happening.

Only of you have all your data available in mSecure on your PC, go ahead and delete mSecure on your phone. Reinstall it from the Google Play app, then sign in to your account. After you set up the app, go ahead and sync with mSecure on your PC.

Do the icons show up correctly now John?

Anmelden oder Registrieren um einen Kommentar zu veröffentlichen