Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!


mSecure Sync error

When opening mSecure on Macbook, iPhone or iPad I receive a Sync Error.
"The file 'ms_508892884.encpdf' couldn't be saved in the folder "attachments" because a file with the same name already exists"
Workaround, remove the file manually and i can sync once and receive the same error

1 Person hat dieses Problem

Hi Ruud,

We have a few other customers running into this problem, but we're not sure why it happens. The only thing I know at this point is that it happens only when using iCloud syncing. Can you try changing to mSecure Cloud syncing instead, then perform a couple of edits to have the database update while using the different sync feature. While still using mSecure Cloud syncing, open your iCloud Drive folder, open the mSecure folder, open the folder that looks like it's named with 10 random characters, then delete the "attachments" folder (this won't cause data in the app to be removed). Now change back to iCloud syncing in mSecure.

Does the sync work now or does it still tell you the same error message?

Hi Mike,
I did everything you asked.
Switched to mSecure Cloud
Removed 'Attachments' folder.
Switched to iCloud sync
Then the first sync is succesful
 Then the error returns

Ok, so the reason this is happens is because the iCloud Drive folders get out of sync somehow, and one of the files in mSecure's folder shouldn't be there but it still is. When this happens, mSecure can't save the file, because it already exists.

Please open your Files app on your iPhone, iPad and Macbook, open the "mSecure" folder, then open the folder that is named with what appears to be 10 random characters. Make sure you open that same folder on all your devices. Next, on your Mac, delete the "attachments" folder. Wait for a few seconds, and then check to see if the folder was deleted on your iPhone and iPad. Do NOT delete the folder if doesn't get deleted on it's own.

After deleting the "attachments" folder on your Mac, was it deleted on your other devices?

Hi Mike,
(I think) I solved it.
The sync error was always with the same file 'ms_508892884.encpdf'.
I suspect that the suffix .encpdf stands for encrypted pdf.
I probably added a PDF attachment in the first 30 days of mSecure 5
Now the free premium period is ended and there was still a pdf attachment somewhere.
I removed the not essential attachments (hopefully included the pdf) and deleted the 'attachment' folder.
After that the sync works again.
I don't know for sure that that was the problem but it is solved now and sync is OK.
Thanks for your time.

Hi Ruud,

Thank you for the follow-up on this. While what you did here may have fixed the problem, it shouldn't have caused the problem to begin with. When your Premium trial runs out, there should be no issues with records that have PDF or Text attachments. They should still sync, and you should still be able to view them. It's just that moving forward, you won't be able to add more of those types of attachments, because adding them is only included in the Premium tier.

Real quick, I'm going to give you some more time on your trial so you can the PDF attachment back onto your record. First, after adding it, does it sync correctly to your other mSecure apps? Second, after the trial runs out, do you run into any problems?

Hi Mike,
Thanks for the help.
I'am OK now

No problem Ruud! Take care.

What's the latest on this issue? I am having the same problem

Hi Christopher, 
During the sync attempt the error mentioned a file name with , in my case a suffix .encpdf
You have to find the entry with the pdf attachment and remove it.
Then remove the attachment folder.
Then the problem should be resolved.

how do I find it? Is that in msecure or are you talking about on icloud?

You want me to delete the attachment folder?

What about all the other attachments?

The problem occurred, in my case, when syncing thru icloud.
When you delete the attachment folder in iCloud you can sync once corrctly and then the error occurs


@Ruud Thank you very much for trying to help with this. It's much appreciated!

@Christopher This sync error only takes place when using iCloud syncing, so the files you need to delete will be stored in your iCloud Drive folder. We don't know why this is happening right now, so we don't have fix yet implemented in the app.

What you need to do is simply delete the attachments as you mentioned. The data stored in iCloud is a copy of the data stored locally in mSecure, so nothing will be lost by deleting that folder. When mSecure syncs again, the folder will and all its contents will be recreated.

Anmelden oder Registrieren um einen Kommentar zu veröffentlichen