Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!


'Cannot access camera' message on Macbook

Trying to authenticate password change on my Macbook using the QR code. Password was made on my mobile device. Msecure says 'cannot access camera' to scan QR code.  Only choice is FaceTime camera or scanner - no scanner that I can find only FT camera.

Advice pls.

Hi Aase,

Thank you for contacting us. The reason mSecure can't access your Mac's camera is because it needs to have permission to do so. You actually should have been asked if you would like to give mSecure access to the camera when you reached the authentication screen, but that shouldn't be a problem. What you'll need to do is open your Mac's System Preferences, then click the "Security & Privacy" option. In the "Security & Privacy" screen, click the "Privacy" tab. In the left column, click "Camera." You should see mSecure in the list of apps on the right. Click the checkbox next to the mSecure app icon, and then you should be able to use your camera to scan your QR code.

Also, I see you have another post in another thread, which I have deleted. We'll talk in this thread to keep our correspondence easier to manage.

Thanks. Was not prompted for a camera access request. But sorted it out in laptop preferences. Sorry to bother you. However somehow my phone does not sync to my laptop because it shows the phone as having an Ethernet connection although both the laptop and my iPhone are on the same wifi home network. How do I change this?

It's good to hear you were able to scan your QR code on your Mac. With regards to syncing, it says "<ethernet>" in the sync settings because there is a permission that needs to be implemented in order to show the actual Wi-Fi network name. That is something that will be fixed in mSecure 6, so seeing "<ethernet>" is not a problem in mSecure 5. As long as both mSecure apps are signed in to the same mSecure account and all of the colors showing in the Sync Settings on both devices are green, syncing should work.

Are all of the colors showing in the Sync Settings of mSecure on both devices green? Also, just to be sure, you are trying to sync between an iPhone and a Mac, correct?

The colour is not green on the connection icon, it’s red. I am trying to sync all the info on my iPhone with my MacBook. I am a little nervous because when I’m signed into my mSecure on the MacBook there are zero entries. There are only entries on the phone’s mSecure. On the MacBook sync settings it does not show my phone. I am sure it is the same account I am signed into so am not sure what’s happening.
Have found a way around my issue by choosing to since my devices through the mSecure cloud. But it was a last resort because I prefer syncing via my private home network. I am not very happy about leaving my info there, in your cloud that is. What happens to my records in msecure’s cloud when I switch back to wifi syncing? Another issue is that on my iPad (running mSecure 5.7.3) the items appear in the menu list but have no content regardless of group or other category. The items are fully detailed on my iPhone and my Mac. Pls See attached screen shot.

BTW my iPad is running iOS 12.5.5

Hi Aase,

It sounds like your iPad's encryption information has somehow become out of sync with your account. I'm not exactly sure how that has happened, but we'll be able to get it fixed. I believe it's happening due to either the password change or the account reset. you performed yesterday, but without a lot more information, I wouldn't be able to be sure. The good news is, everything is working on your Mac and iPhone, so we can reset everything on your iPad, and that should fix it. Once all your devices are syncing, then something like this should never happen again.

In order to fix the problem with your iPad, I'm going to have you simply uninstall and reinstall mSecure on that device. Go ahead and tap and hold on the mSecure app icon, then tap the option to "Remove App." After that, tap the "Delete App" button. Now that mSecure has been deleted from your iPad, open the App Store app, find mSecure, and install it again. After it's installed, go ahead and sign in to your account, and that should fix the one problem with the records not showing your data.

Regarding syncing, nothing happens to your information when you change from mSecure Cloud to Wi-Fi syncing. The encrypted data stored in your online account simply gets removed, but it remains as is on each of your devices. I think what happened before is that your Mac mSecure app was not set to be the "Main Computer" in the sync settings. After you have followed the steps above to get your iPad fixed up, let me know, and we'll work on Wi-Fi syncing.

OK all set with my records synced to all my devices and all records showing as they should. Thanks Now to switching to wifi syncing?

It's good to hear everything is synced on all your devices. What I'll have you do now is open mSecure on your Mac, then open mSecure's Preferences by clicking "mSecure > Preferences" in the menu bar at the top left of your screen. Click the Sync tab in the Preferences, then change syncing from mSecure Cloud to Wi-Fi. You'll be told your data will be removed from the mSecure Cloud, which is what you want. Your data will remain intact on all your devices.

Next, after changing to Wi-Fi syncing, make sure the "Main Computer" box is checked. This designates your Mac as the server of your data. After that box is checked, close mSecure's Preferences, but leave it open and unlocked on your Mac. Open mSecure on only your iPhone, unlock the app, and then create a quick dummy record to see if it will sync over to mSecure on your Mac.

Did that have any effect on the issue?

Thks Mike. Unfortunately it did not sync the test item. ‘Sync error’ Wvwn though the Macbook is designated as main computer. The sync settings on my iPhone show the ‘disconnect’ icon between the two - see attached.

Ok, it looks like there is a problem with the connection between your iPhone and your MacBook. I thought what you were saying earlier is that "<ethernet>" was in red and not the connection graphic between the boxes. What this means is that your devices are not able to communicate with the IP Address mSecure has. In order for Wi-Fi syncing to work, first the devices have to be able to communicate on a hardware level before they will be able to communicate on a software level. The red graphic indicates there is a problem with hardware communication.

As long as the IP address you are seeing at the bottom of the sync settings in mSecure on your iPhone, your devices should be able to communicate with each other. I can't see the IP Address in the screenshot you attached, but that's something I would need to look at to see if there is a problem. Can you look at your Mac mSecure App's Sync Settings to get the IP address there, then cross-check it in that bottom box in the Sync Settings on your iPhone? Do the IP Addresses match?

The IP addresses do match.
Can it be a firewall issue?

I just received an email response from you Aase, so let's continue our correspondence via email instead. It's more private that way, and I can get actual data from you regarding your IP Address there if needed. I'm responding to you now via email.

Anmelden oder Registrieren um einen Kommentar zu veröffentlichen