Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!


Importing problem

I tried importing my data from the previous version of MSecure to v5, but when I went through the steps for migrating and didnt have my password, it installed a clean version of MSecure using my current account and profile. Now there is no option to import my data, and even tried deleting the app and re-installing it but now it doesnt even ask to import or sync data..Is there a way to initiate the migration process again?

Hi Jon,

I believe I just responded to you in a different thread. We'll continue correspondence in that other thread if needed.

I have that problem also.   mSecure 4 will not even open since the recent iOs update.  Opening mSecure 4 seems to be the necessary first step in migrating data to mSecure 5, so I don't know what else to do.  Please help!

@Daniel I just responded to you about this issue in the other thread your created. We'll continue our communication in that thread.

I am in a similar predicament. I've been locked out of my mSecure 4 when I upgraded to iOS 14.5 yesterday. I was not even aware there was a version 5 until I found your "iOS Issues and Discount" in the Discussion>General>Announcement feed. I followed the recommended process in that feed but the problem is I have been using the Fingerprint ID feature in mSecure 4 for several years that I have no recollection of what my original keyed in password was for mSecure 4. Therefore I am unable to import my mSecure  4 data on my device or my .msim backup to mSecure 5.


Hi Scott,

Thank you for contacting us, and I'm really sorry to hear about the issue you are experiencing here. Since the older mSecure app did not have an account system, there was no way for us to be able to notify our customers of the new mSecure 5 app released a few years ago. We did add a page in the app that popped up every once and awhile when the app was opened, but if the version wasn't the newest v4 release, or if the user chose to close the window without allowing to reopen, it's possible the page wouldn't be displayed. I am sorry you didn't see that page notifying you of the availability of the upgrade.

Regarding the problem you are facing, since we don't acquire your password or your data, there is no way for us to retrieve either of them for you. Is it possible there is a substitution character you are not entering correctly? For example, many people use $ for S, 3 for E, @ for a, etc.

I have this exact same issue.  My msecure password is probably saved in msecure 4... which by the way was probably the most recent version because everything auto-updates on my phone.

Can't you just add the fingerprint option into msecure 5 where it requests the msecure 4 password?  why isn't it there now?  I have seen that page that was mentioned but skipped it for many years as it offered me the option to purchase a different app.  I didn't need another app as msecure 4 was fine for me.  I never read a warning on that page saying that i would be locked out of msecure4 in the next ios update.

@Sean Unfortunately, due to the way Apple has implemented Touch/Face ID, what you are asking for here isn't possible. If apps could share that information, it could lead to all sorts of security concerns. Since mSecure 5 is a different app than mSecure 4, meaning they are a different app bundle uploaded to the App Store, they cannot share the Fingerprint/Face information stored in the device's hardware secured location (the Secure Enclave).

With regards to a warning, we didn't have a warning for this either. On every iOS release, we run mSecure 4, and on our devices, much like the vast majority of our other customers, the app runs without any problems. Had we have known this was going to happen, we would have changed the messaging on that screen to warn our customers. Apple doesn't send out warning that something like this might happen. Also, there is no way for us to send an email to our customers running v4, because that app doesn't have an account system. Because of that, we don't have the email address for any running mSecure 4 or older.

So is there any possibility that you folks will be doing an update to your app so that it works again? I’m so screwed here. Dang. I just tried to use an old backup to upload into the new app & that won’t work without the old password either.

Hi Sean,

Since the app has been unsupported for around 3 years, we won't be updating it now. I'm really sorry I'm not able to help with this. We're finding there are a handful of our customers running into this situation, but we're not sure of the best solution when it comes to helping with remembering passwords when Touch/Face ID is enabled. For some systems, the require the user to enter their password every so often, but we're not sure that bothering users in this way is the best route. We hope to find something that will provide minimal intrusion but still helps in these types of situations.

Anmelden oder Registrieren um einen Kommentar zu veröffentlichen