Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!


No iCloud sync between IOS and OSx

Hello All

After upgrading from mSec 3, 4, to 5 on IOS, installed the iMac version on Desktop.

IOS is working flawlessly but there are no PWs on the desktop. Icloud sync has been selected on all devices.

The correct user ID is selected for iCloud on all devices (Three in total)

Please assist to get sync working on Mac..... 

Many thanks


unhappy upgrader !!!

Hi Neils,

Thank you for contacting us and I'm sorry about the issue you are experiencing. In order to sync in mSecure 5, you need to be using mSecure 5 on all devices and be signed in to the same mSecure account in mSecure 5 on each device. Additionally, if trying to use iCloud syncing, you must make sure to use the same iCloud account on each device. Thankfully, it sounds like the iCloud accounts are the same on all device. 

Are you using mSecure 5 on each device? Are you signed in to the same mSecure account on each device? Have you tried to manually sync?

On Mac:

1. Open and unlock mSecure 5

2. Click command+shift+S or File > Shift

To manually sync on iOS, please have at least one record on iOS or create a test record and follow these steps:
1. Tap and hold the top record
2. Drag the record down and release

Hello Eden

Thank you for your prompt reply!

1. All devices use iCloud for syncing, IOS and Mac, sync OK for all other apps like Calendar, Photo etc. All checked this morning.

2. mSecure is listed in iCloud iDrive as an APP with the other Apps.

3 The two IOS devices have always synced in all versions and still do in v5.6.0 IOS 

4. The Mac OSx is a new install and never had mSecure before.

5. Manual Sync does not work on the Mac! No error msg at all. just not syncing!

     If you have access to the developers, they need to understand that their coding  masterpiece is not perfect and innocent users might like to get

     some clues, like meaningful error messages to give a hint as to why their Masterpiece is not performing as it should. 

6. Mac is using V 5.5.0, IOS devices 5.5.6, all dl from APP store and iTunes on the same day.

7. It is not clear how WiFi syncing is set up on Mac for mSecure 5. Have you anything on WiFi syncing mSecure 5?

8. The same PW is used for all APPS and mSec account. Maybe I should change that

Please assist


HI Niels,

  1. Your iCloud syncing settings in other apps do not matter. mSecure 5 syncing requires mSecure 5, the same mSecure account in mSecure 5 on each device, and to be using the iCloud account on each device.
  2. That's good. That means that mSecure is allowed to use iCloud on the devices that show that
  3. Ok. Are you signed in to the same mSecure account in mSecure 5 on your iOS devices as you are in mSecure 5 on your Mac? (iOS: Menu > Settings > Account Settings. Mac: Preferences > Account)
  4. See answer 3
  5. See answer 3
  6. See answer 3
  7. You are using iCloud syncing in mSecure 5 (at least for the account). WiFi settings do not matter when using iCloud syncing in mSecure 5. 
  8. I don't understand this. An mSecure account is new with with mSecure 5. mSecure accounts are accounts in our systems. An mSecure account cannot have a different password on different devices. mSecure 4 and below use device specific login passwords. That is why you could have different login passwords in the past.

Hello Eden

All devices use the same V5 account log in. Right from the first start!

The iMac Desktop mS 5.5 has no data ie it is empty.

From the attached screenshots you can see mS app is using system resources without actually achieving anything. It will keep doing this for hours on end and not stop until you force quit.

The  mSecure Desktop v5.5.0 is obviously buggy and needs to be fixed by the Developer!

The Desktop mSecure App is useless in its present state of development.



Very unhappy mSecure customer!!!

I wish I had never heard of the upgrade, it seems a total waste of time and money!

PS Ignore point 8 

Hi Niels,

 mSecure not showing any activity isn't issue on it's own. Can you show me the account settings showing your account in mSecure 5 on each device?

On Mac:

1. Open and unlock mSecure 5

2. Click mSecure 5 from the top menu bar and select Preferences (command+comma)

3. Click Account

4. Take a screenshot (command+shift+4):

On iOS:

1. Open and unlock mSecure 5

2. Tap the menu icon

3. Tap Settings

4. Tap Account Settings

5. Take a screenshot:

mSecure 5 is not buggy and there are no known issues with our syncing. Obviously, it's not working for you, but this is likely due to either some settings on your devices, using different mSecure accounts in mSecure 5, and(or) using different iCloud accounts. I'm confident that I can help you figure out what setting is the issue here and help you start syncing. 


A little CPU activity for a short time would not be a problem.

However, continuous CPU activity during cloud activity is not!

Nor is the level of App support in any way acceptable!

Eden, you tried to support and for that I thank you.


Fallen for nag msg v4 Msecure and paid for an upgrade that is buggy!

Unresolved cloud sync issues

Hi Niels,

Unfortunately, I can't help without the information I requested. Did you check to make sure you are using the same mSecure account in mSecure 5 on each device? Are you using the same iCloud account on each device? Can you temporarily switch to using our mSecure Cloud syncing feature instead to see if that allows you to sync? I have ran into issues with some customers where their iCloud accounts were not working correctly. To fix the issue, I had them sign out of their iCloud account and back into the account on each device. That seems to fix iCloud issues some customers were experiencing, If you are using the same mSecure account and iCloud account, perhaps you can do that as well to try to fix your iCloud issues here:

Anmelden oder Registrieren um einen Kommentar zu veröffentlichen