Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!


Giving up on 5

This probably won't get posted, but I feel I've made a solid effort in attempts to use version 5.5, having spent about 7 total hours and numerous support emails etc.  I can't see a good reason to use 5.5, since automatic Sync doesn't seem to be reliable (I'm using iCloud - haven't tested anything else.)  I don't really like the new interface and find it cumbersome to use compared to version 3 on desktop (Mac.)  I also don't see value in the new architecture, tying to an mSecure account password (I like the old way with master password to encrypt.)   I think I'm going back to version 3 on Mac and 4 on iOS and may revisit again if the product changes.  If not and I'm forced to give up older version at some point, I may look to Lastpass or something else.  Disappointed.

1 Person hat diese Frage

I'm in the same boat, Brad. I just migrated to LastPass.

mSecure 5 has been a big step backwards in every way, and it finally got to be just too much to deal with.

The new user interface has way too much white space, and demands too much screen real-estate. I need a huge mSecure 5 window to see what I need to see, compared with the old version. The interface is now made up of similar icons scattered around the window, instead of a proper macOS toolbar like mSecure 4. Things that used to be simple single-click operations, like sorting by type, are now a click-and-scroll slog through a mobile-first list interface. 

The macOS app is like a half-hearted port of an iOS port of an Android app. It violates UI conventions: for example, Groups and Types. These are disclosure lists. But there's no visual indication of this. If you single-click on those words or icons, nothing happens. If you double-click on them, nothing happens. But if you hover over them, the text "Show" appears, and clicking that text causes the disclosure list to appear. On macOS, disclosure lists are represented by a triangle icon, and double-clicking on the heading of the disclosure list should cause it to appear or disappear.

"Security Center" is a meaningless red number, because after a while it starts complaining that you have passwords that are more than three months old. You can't configure how long is "too long" for an unchanged password. Plus, current industry guidance is that you shouldn't change your password unless it is weak or has been compromised; that old "every three months" rule is obsolete and dangerous, and contrary to the latest NIST guidance.

The iOS app took some big steps backward, too. In version 4, you tapped on a password to copy it to the clipboard. Now, you have to tap it, and then select the "Copy" pop-up from the small system pop-up menu. It feels a lot slower.

While we finally got Wi-Fi syncing, it's not as useful as it was in version 4. Sure, in version 4, one had to do an orgy of device-to-device syncs to get several computers and mobile devices up-to-date. Now, there's one "main" device that everything else syncs to... but that means you have to have the main device unlocked to sync, and that's often not practical. It turns out the old cumbersome "sync is between a mobile and a desktop device" worked better, because you could take the mobile device with you to each desktop that needed syncing, and unlock it there...

mSecure's supposed cross-platform functionality was a requirement for me. But I've found that the Windows 10 client rejects my mSecure account password—the one that works fine on all my macOS and iOS devices. I contacted support, and got back a verbal shrug and a link to a "forgot your password" page... two days later.

In mSecure 4, you could change an entry's type. In mSecure 5, you're locked in when you create it.

mSecure 5 is filled with little annoying bugs. For instance, on the macOS client, sometimes the "Copied to clipboard" banner never goes away until you change records... which prevents you from copying the password again. On iOS, the Safari plug-in stopped working with iOS 11.3.1. On iOS, if you select "reveal," the app decides on its own when it should hide the password again... often too quickly for you to use it. (There's no way to adjust that timeout, which I swear seems random.)

Unfortunately, going back to version 4 isn't a viable answer. It's no longer available for iOS, which means that it can't be loaded to new iOS devices.

I really liked mSecure 4, and I really wanted mSeven to succeed, but mSecure 5 has just been a debacle from day one and it hasn't really gotten better. Maybe I'm not mSeven's current target market (tech-savvy IT security professional at Fortune 50 company); I hope the redesign got them enough business to make up for those they've lost. For me, it's driven me to the competition.

Robert I really appreciate your response because I was beginning to think I was an unusual case.  You've articulated the issues really well (better than me, apparently I came across as "complain-y" to the mSecure folks.)   I sincerely hope that they are working on a version 6 that is much better.  I'll continue to use the older versions of mSecure as long as I can (until I get a new iOS device, I guess) but I will certainly also begin re-investigating the alternatives like Lastpass (there are things I don't like about Lastpass, too, though.)

I'm sorry you guys don't enjoy the changes. I don't have much to add here because I'm not here to defend what is your opinion. However, I do feel the need to correct a few things said here.

  1. mSecure 4 is no longer for sale. However, all app stores allow you to redownload purchased apps. We have a guide to help you learn how to do this on all platforms here:
  2. The mSecure account password will be exactly the same on all devices. If one platform is not allowing you to sign in, you are either trying to use the wrong app, trying to use the wrong credentials for the wrong account, have typos in the email or password, or have un-needed spaces in the email or password. There are no other customers having issues signing in to the same mSecure account on all platforms so this would seem to be user error. You can also always change your account password on any device you are already signed in to:
  3. The Security Center has suggestions for security strength. It doesn't force users to change their login password no matter how old or new they are
  4. I do agree that our Mac app does needs more visual cues about actions you can do. There are no hover affects, an the mouse pointer does not change to a hand pointer for items that are clickable. We're working on adding these to the app. The Windows app is also missing several tooltips that we plan to include soon as well.
  5. Yes, some changes will make it so that some old methods no longer works for particular setups with Wi-Fi syncing. However, from feedback with received, it seems our WiFi syncing changes seem to have helped more people now. That said, we have had a bit a feedback asking for syncing with the "Main computer" to be allowed to happen even with the app locked or having a background service enabled so that the "Main computer" can always continue to sync. We are keeping that in mind moving forward.
  6. The mSecure Extension does have a bug that will be fixed in an upcoming update soon.

We get that the new app won't work for everyone, and that is ok. We certainly do not wish for our customers to be unhappy every time they open the app try to make use of it. If you are in a place where you feel a refund is necessary, please let me know.

You can email a backup to yourself the import it to the new version. This worked for me, I was about to give up too.

Kommentare zu dieser Diskussion sind jetzt geschlossen!