Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

base di conoscenza Invia un biglietto

Moving from Passwords Plust to mSecure Import issue

Good day folks, I'm not happy about loosing Passwords plus at all but when given no choice you do what ya gotta do. 

So I'm here and the first issue to appear is a special import feature for PWP users seems to be only available if we purchase on of the version of mSecure. 

Since Msecure is offered as a trial and that's exactly what I need as I'm going to be talking to a lot of my clients I want to fully vet this transition first. I down loaded from the MS store for Windows PC and the only option I saw to import was from some previous versions of mSecure. Obviously that dosen't help. 

How can we complete this import from PWP? 

I saw no other import options once setup was completed. 

5 persone hanno questo problema

I only have the passwords from a to n imported and then a whole bunch of data that has nothin but a question mark 

Same issue here.  It only imported entries through "R" and nothing after. I tried the export again, putting my cursor on the last entry and now I have duplicate entries for everything., but still only through "R".  My husband and I rely on this for everything. We need to get a solution before we can't get into PWP anymore.

I had the same issue. 

Only 126 records were imported into mSecure from the 667 I had in PasswordPlus. 

I manually deleted all fields which had carriage returns (mostly Notes). They were easily identified by the apparent big white gap in the Excell rows (actually big row height). 

I deleted all the previously imported records from mSecure to prevent creating duplicates. Then I  imported the cleaned-up CSV file. 

This worked, but obviously, I no longer have the data I deleted in mSecure. Pity!

I did the same, but did not delete the fields with carriage returns, merely copied them elsewhere pending the import of the bulk of the PWP records into mSecure, and then updated the records copied into mSecure using copy and paste.  It was fairly laborious, but I did manage to transfer 436 records in about 4 hours altogether, and the records in mSecure appear to be identical to the records in PWP.  I now wonder whether in fact all I needed to do was to open the .csv in Word, replace all carriage returns with an unusual character that would not be found elsewhere in the data, say a ## or ~~ (double hash or double tilde) and then import the resulting .csv into mSecure.  I don't know and have not tried because, having sorted out my transfer to mSecure, I do not want to mess it up.  However if it works there is no need to spend any time effecting the transfer.

I contacted PWP support and got the following from them - it implies that if we wait long enough PWP and mSecure are working on a fix..... Apparently this is a Windows related issue and the import is supposed to work OK on a MAC. But I don't have one......

We are working with mSecure on a fix for this problem and hope to have something very soon. Please be patient while we work this out.


Some workarounds (although you don’t have to try these - we are planning for a fix)


It does appear that the issue is only on Windows so if you have even temporary access to a Mac, you can try to do the import there. Even if you don’t plan on using the Mac going forward, you can just use it for the import, then sync and log into the Windows version and things should work correctly.*2 (This is not a confirmed fix but was reported by another customer). Use a text editor to convert single and double quotes to another character within the exported CSV file - or go through the data in PWP and remove all quotes.


You do NOT have to do this - as I said, mSecure is hoping to have a “real” fix soon. But if you’re up for it, you can give it a try.


If you do either of these workaround and they work sufficiently, please let us know.


We will update this page as well as email you when we have a resolution to this issue

I've been in contact with PWP support - they say they are working with mSecure on a fix for the Windows import (apparently the MAC import works fine - so that is a possible workaround for those who have access to a MAC).  No indication of how long this will take - but in the meantime I have observed that the export from PWP does not always put the notes in the Notes field in the csv file (the last field); sometimes, and I have not yet identified why, it puts them in FieldLabel6 column. These need to be moved to the notes column; if not, they get snarled up with comments from other records.

Also, AND THIS COULD BE A REAL PAIN - any leading zeros in a PWP bank account (checking account) field, get removed when it is exported. So 00148905 becomes 148905.  

You really do have to hope that mSecure/PWP get their joint act together. Like others, I am astonished that PWP did not ask their customer base if they would be prepared to go down the subscription route. I bet the majority of us would have done so, given the hassle and stress of transferring. Shame on PWP.

My banking entries were all bunched up together in my first attempt at importing. The total count at that time was 144 records. I just went through this banking group in PWP (they all begin with an "n", so it was easy) and in PWP I deleted any unnecessary Notes. I then made the rest into long text strings by manually deleting the "Returns" that were creating the separate lines (I could easily put the lines back later in mSecure, I expect/hope!).  I exported a new .CSV file from PWP and I deleted all the (144) records previously imported into mSecure, so it was empty. I then ran the import function again on the new .CSV file and got 178 records! All my banking entries are now separated into individual records. I just did the same with another group and now I've got 208 records. NOTE: The Notes entry in PWP for the record that seemed to be triggering this second "cluster" appeared to be just one line. In fact, in the PWP editing display, I could see that there were several blank lines after the visible text ended. I backspace deleted these blank lines back to the end of the visible text! Result, after yet another .CSV file/import, the "cluster" is broken up and the individual records recovered and visible. Now my count is up to 208. It seems to me that, as W and others have said, multiple lines/Returns in the Notes field of PWP really cause problems. HTH

All done.  All Notes field content now in single line text format. Redundant Notes data has been deleted. Blank lines and (invisible) empty lines deleted. 450 records into mSecure. All clear and ready to go.  Phew!

I spent several hours editing the Notes field in PWP by deleting the carriage return and substituting a space. I exported to CSV. Deleted existing records in mSecure. Imported from CSV to mSecure.

Only 167 of 667 records were imported. Substituting a space for a carriage return did not work.

It is possible a carriage return might be in another field. Mine were not confined to Notes. I also had some in another column (field 10). However you did slightly increase the number of records imported. Unless you are certain there are no other carriage returns in your file, it is difficult to say categorically “substituting a space for a carriage return did not work”.

Be aware that any large "numbers" e.g. credit card numbers (16 characters long in that case), may get exported from PWP as exponential numbers and you will lose the individual digits.

When I delete the contents of the fields (whether Notes or other fields) which contain the spaces which I substituted for carriage returns I am able to import all 667 records.

My final (?) check of individual records in mSecure disclosed 13 records which I had missed and still contained "nested" records ie errors. Checking these 13 one-by-one in PWP I found that there were extra , invisible lines/returns, in the PWP Notes section in 11 of them. I edited out the invisible extra returns that were producing the invisible extra lines. ie go to end and "Backspace" delete back to the final wanted character.  I then deleted/edited the contents of the PWP Notes field on the remaining 2. Just checked and ALL now free of errors and record count imported from PWP to mSecure has now gone from previously 450 up to new total 542. That's it - I hope!

I certainly appreciate what everyone here has done, but that is only a fix for you or the knowledgable. We need a working import feaature that handles PWP as it is. Once again I have a slew of clients that have no clue about this stuff and they should be able to follow the simple export / import routine. Awaiting to here what they have to say. 

Exactly my feelings about this. I don't know anything about what everyone is deleting and adding in the file. I shouldn't have to. You would expect the migration to be seamless, but since it obviously isn't, I need someone from PWP to assist me with all the changes. Hopefully they respond to you before the deadline!  I will also contact them.

Accedi o Iscrivitiper pubblicare un commento