Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

mSecure Support

base di conoscenza Invia un biglietto

"Server is unreachable" when trying to do wifi sync

 Want to wifi sync, but I get a "Server is unreachable" on my Android phone.  When I go into settings, I can see my main computer's name, which is also listed in the desktop app's Sync Settings section. How do I troubleshoot this?

5 persone hanno questo problema

Have you read this?

The part that fixed it for me was changing the setting to Private Network

I have the same problem now and had it in past too. I was solving it with Eden for beta already and for the production version in January too. I know your generic instruction. I have a 100 % correct setting on my PC and Android phone based on it. The only solution was a complete repeated removing, reset and reinstallation of mSecure both on the PC and phone in such situation. I did it the last week for the same reason, the sync was OK just after it, but the next day the message "Server is unreachable" was back again. It is „a little bite tiresome“ reinstalling your application several times each month!  

Andy: Thank you, that worked! 

New problem (maybe I should start a new thread): All the records from the desktop have been synced to the mobile (android) phone. But they don't actually appear under All Records: it's blank. Recent Records is fine. I can also search for a record in All Records and matches will appear. It just won't show anything in the default state. Neither in the logins category, which is the bulk of the records. It could be because I have about 900 records (don't ask!). Is there a limitation under the number of records mSecure can comfortably handle?

Hi Vladimir,

There shouldn't be a reason for you to reinstall our app several times a month. If our app is telling you that the server is unreachable, you are having local networking issues. The easiest fix for that would be to restart your router and your devices to see if that fixes your local networking issues.


Hi Deetee,

My first recommendation would be to restart your device and see if that fixes your issues. Also, if this is an issue with mSecure 5 on your Android device, please make sure to update to mSecure 5.5.3 to see if that also fixes your issues.

Eden, thanks, I will try it next time. Today I fixed it by reinstalling already. I really deeply checked all network and firewall settings before it and I did not see any difference before and after reinstalling the application. And the sync started to work after the reinstallation again.

Hi Eden,

Yes, it's Android and I'm on the latest app version. Unfortunately, restarting the phone didn't help. See attached. Like I said, if I run a search for records, results will immediately pop up. But if I "x" out the query, It'll go back to a blank screen. 


I'll go ahead and open a ticket.



I'm sorry I didn't respond sooner. My recommendation here would be to either reinstall mSecure 5 on your Android device, or go through a backup and restore: to see if that fixes your issues here.

Hey Eden,
Tried both solutions: no dice. It's not a tragedy. I can still search and the relevant records will appear. And I can favorite items, which will show up if I toggle to favorites. All of which is leading me to think the issue is too many records.


How many records do you have? I haven't had any real issues with up to 4 thousand records. Around 10 thousand the app does start being slow and not so fun. Did you do both a reinstall and a backup and restore here?

900 records--so I guess that's not the issue. Yep, I tried a reinstall, as well as a backup and restore, but didn't fix the issue. I did a migrate from SplashID, btw. I exported to CSV, fixed the columns and fields, and imported into mSecure. Maybe that's part of the problem. But, the records do show up fine under "recent" and when I do a search.


So here's something interesting: When I change the sort from "Name" (what it's been defaulted to), the records all show up. I have it now sorted by "Group," but any one of the sort options, except Name, will display all the records. I cycled through all the sort options, and then went back to "Name," but weirdly, records will still not show under that sort option. Since all my records are basically "personal," sorting by group is fine, so I consider this a good enough solve.


How did you program msecure? It is so secure that you need to reinstall it several time ... are you serious?

I am not really too enthusiastic about this "automatic" non running feauture... better the one on msecure 4, where I could give the IP address...

Hi Fabio,

I'm not sure what you are referring to here. Can you please create your own topic detailing exactly what your issue is or might be and provide devices, version, etc, instead of jumping in to someone else's old topic? I'm closing this topic now. Thanks for re-opening it.

I commenti a questa discussione ora sono chiusi.