Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

Support mSecure

Android mSecure 6 update nonexistant

I use mSecure on both my Windows and Android devices and have for many years.  My windows machine automatically upgraded from mSecure 5 to mSecure 6, and told me I have a premium trial.  So, I logged into the website and purchased a premium subscription.  I then opened the app on my tablet and phone to see if the premium account was there as well.  The app pops up a window stating "Update required" with two options OK and View on Play Store.  I click View on Play Store and it takes me to the mSecure page on the Play Store, but there are only 2 options: Uninstall and Open.  I click Open and it takes me back to the Update required pop up.  I then clicked on Uninstall and Install.  After installation, I open the app and signin and it tell me Update required and now I can no longer access any of my information.  

How can this be resolved.

1 personne a le même problème

Hi Darrell,

Thank you for contacting us, and I'm sorry for the issue you are experiencing. The Android version is being rolled out on a gradual basis, so those who have access to it are chosen at random by the Play Store. Everyone will have access to V6 after about a week. Unfortunately, if the Store is giving you V5, there is no way to force it to give you V6, so it's just a waiting game at this point. If you wanted to use mSecure 5, you can restore your data from a backup if you have one. V5 is functional, it's just that the data in the app can't sync.

No I don't think you understand. The way you have programed the app once you uninstall and reinstall, the app does not allow you to actually log back in.

That's not true Darrell. We didn't program the app to not allow you to install the app after it's been uninstalled. That's actually not possible for us to do that, because Google Play would not allow it to happen. The Play Store is fully responsible for the app being installed, whether it's been installed previously or not.

Something's going wrong here, but it's not in mSecure's program. You can install, and uninstall the app at will any time, and when it's installed again, you can sign in to your account. Right now, what state is the app in? What happens when you try to sign in to it?

Mike,  maybe it is not true, but let me explain what I am seeing.  

1) The app is installed.  The play store says so and allows the Open button to be displayed.  

2) The Open button is clicked and the app starts.

3) The app gets to the singin screen and takes the credentials.

4) Then the popup opens stating that "Update required"

5) Clicking "Veiw on Play Store" will have no valuable effect because we have already established that mSecure 6 is not there

6) So the only possibly useful option is to click "OK"

7) Clicking "OK" take you back to the Sign In screen to enter your credentials again

8) You are now in an infinite loop putting in credentials, getting the popup, pressing OK and around you go.

You are correct that I don't know who (Google or mSecure) is responsible for the popup window.  I assumed it was mSecure.

Given this infinite loop, there is no way to restore a backup file or anything else.

The reason this is happening is because mSecure 6 is not available to you in the Play Store yet. As I mentioned before, the new version is being rolled out gradually, so not all users have access to it in the store yet. Those who have access were chose by the Play Store randomly, and we're at about 50% of our user-base so far that have access.

For further clarification, the upgrade notification is not being displayed because Google Play decides it's needed. The app sees your account has been upgraded in our cloud system, which has no connection to Google Play. When this happens, it tells you the app needs to be upgraded, and as soon as it is available, you will be able to download the update. Until then, you'll need to dismiss the upgrade notification, and you can continue using V5. The only thing that's different is changes in V5 will not be synced. All changes will be resolved when V6 is installed.


Let me give you some constructive feedback.  I totally get that you needed to change your business model and go to a subscription model.  You did very well with the communication of that.  However, in the actual execution of this, you have violated the element of least surprise that is paramount in all business dealings.  I don't know what is actually supposed to happen or if you knew that people would have this delay in upgrading from the Play Store.  But it is absolutely the wrong thing to uninstall and reinstall.  With that knowledge, communication should have been provided to the users BEFORE the transition NOT TO UNINSTALL in the process of trying to upgrade.  That pop up window could have had a third link to communicate the details and expectations.  It appears to me that one thing that is really important in this communication is that one should not actually upgrade to the premium version until all platforms have upgrades available.  

From my perspective you have in our conversation here absolved yourself of virtually any and all responsibility.  I don't agree with that.  You as the developer/app owner have the responsibility to enable the transition for your customers to be as easy as possible.  A fundamental part of that is for the customer to not loose connection to their data.    A large part of that is clear communication and managing expectations for your customers.  That did not happen in this case. That is clearly on you.

I have been a very loyal customer for many years.  I have been responsible for leading a number of other customers to you and they are now using your app.   In the old business model that does not necessarily add up to much revenue for you.  However, in the new business model it could actually be substantial.  

You probably don't care about my thoughts on this, and that is fine; however, this could have gone better and you play a major role in that.


I'm having the same problem as Darrel. In my case new phone and so new install of the app. I can't log in, the app is forcing me to an update on Playstore that doesn't exist. Reading the conversation above, I totally agree with Darrel. I don't care about te reason why Playstore does not provide the upgrade to me. I've bought the app and I just want the problem to be solved. Pointing to Playstore is way too easy in my opinion, you've changed your plan and I can't acces my passwords at the moment! Looking forward to a Quick fix, Kind regards Wouter

Takes brass posting This:


The reason this is happening is because mSecure 6 is not available to you in the Play Store yet. As I mentioned before, the new version is being rolled out gradually, so not all users have access to it in the store yet. Those who have access were chose by the Play Store randomly, and we're at about 50% of our user-base so far that have access.

and this:

Everyone will have access to V6 after about a week.

Wait a week ?  Not acceptable.

Darrell and Wouter are way to nice.  You should never have released the platforms separately.  Improve your outsourcing.

I am having the same problem.   I can't access mSecure on my new phone. 

mSecure you don't get off the hook for this.  No Trump swapping.  You new there would be an issue with the way the Play Store rolls out upgrades.  I can't get to my data by 3/23 will be cancelling my new subscription to mSecure 6 and moving to Keeper.

I tried to comment here and they bumped my comment.  Probably because I told them they have 2 days to fix it or my wife and I will be moving on.  I have a new phone and I have to have access to my stored data.

I have to agree with Fxpiano.  Darrell and Wouter ARE way too nice.  This crap of blaming the Play Store is enough to make me change apps and leave mSeven in the dust.

Apparently Mike doesn't have a clue what his software is doing to users.  If a person uninstalled V5 on their Android device hoping to upgrade to V6, they are, unfortunately, out of luck.  V5 goes into a loop of saying you need to update but brings a user back to V5 in the Play Store (because it wasn't rolled out to everyone!), but will also NOT LET YOU RUN THE APP AND ACCESS DATA.  It is completely closed off from use if uninstalled and reinstalled.  Horrible, horrible planning on mSeven's part.

Communication about the Play Store rollout should have been front and center in the emails sent out to users.  I wouldn't have uninstalled the app if I had know that I had to wait a week to "get access" to a new version.

Seriously frustrated here.

I did recieve a reply with the same answer as before, we have to wait until the new version is rolled out to everyone in te PS. The only 'help' was pointing me out to acces my data through another device. I consider this a major shortcoming in understanding and customer focus. I've decided to switch to Keeper.

I agree with all of the above! I have a slightly different problem. I finally received the update on Google Play a few days ago on my phone (Pixel 6 Pro) however when I tried to update the app on my Google Chromebook I get the same update loop that has been mentioned previously. I cannot log back in to version 5. On the other hand I was able to download the chrome extension for version 6 but it's useless because I still can't download the app on my chromebook. Is msecure compatible with the Chrome OS?

@Everyone This morning we have published a new version of mSecure 6 to the Play Store, and it will be available to everyone - no gradual rollout. I'm not sure how long it will take to reach everyone's devices, but you should have access to it by the end of day. Please check Play Store throughout the day to see if it becomes available on all your devices, and that should take care of the problem you reported.

Connexion ou Inscription pour poster un commentaire