Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

Support mSecure

IOS 14.5 requires update

mSecure has to be updated in order to work with IOS 14.5. SO do NOT install 14.5 as long as the app. is not updated. If it is not fixed  within a few days I will stop using this app. It  is too essential and should work all the time.

39 personnes ont le même problème

I also had success with @herve's technique after the mSecure 5 version migration feature didn't work (tried account reset several times -- using iphone 6. To clarify, mSecure 4.5 now works on my phone again. I went ahead and enabled the cloud sync feature hoping it will facilitate migration to mSecure 5 but now I need to get some work done. 

@Eleanor Though it is possible to get mSecure 4 back and working on some devices, staying with that version of the app is not something we recommend doing. If you were able to re-install from the App Store app, then you should now have no problems migrating if you were to reset your mSecure 5 account again. The reason why the migration wasn't working before is that the version of the old app on your device was older than v4.5.4. If you recently installed v4, however, you should now have v4.5.4, which you can confirm from inside the app's Settings. If that is confirmed, then you can reset your mSecure 5 account, reinstall mSecure 5, then sign in to the account to trigger the migration.

@Mike, actually now I have v4.5.1 and reseting and trying to trigger the migration with the mSecure 5 version still did not work. It seems like this version does not have access to the mSecure cloud back up system but it does access iCloud. Yet I wasn't able to trigger the reset regardless. Any further suggestions appreciated. 

@Eleanor The migration can only work if you have mSecure 4.5.4 installed. None of the versions older than that support the shared app space needed for mSecure 5 to be able to see it's data. Also, the older version of the app does not have an account system at all, so it is not tied into the mSecure Cloud, and if you are using iCloud syncing in the old app, it doesn't help, because the new app can't make use of the sync file. The only way to transfer data from the old to the new is using the migration feature or by making a backup in the old app and then restoring from it in the new app.

Real quick, when you open and unlock mSecure 4, do you see all your data?

No I couldn’t see my data so thought it needed to be updated and tried to reinstall app which of course I can’t find anywhere now so all my data is gone? Terrible there was no warning or explanation

@Mike, yes all my data is there in the mSecure 4 version having followed the instructions outlined by @herve. So I need to update to the next version, mSecure 4.5.4. How do I do that? 

@Christian Unfortunately, it was not possible for us to notify our long time users that the old version was going to be negatively affected by recent iOS updates. Since there was no account system in the old mSecure app, we don't have the email addresses of those customers, so there was no way to contact them via email. In addition, throughout all our testing before each version of the iOS releases, our devices didn't exhibit the problem some of our customers are running into here. We still are not able to reproduce what is happening on our devices, even after running the first beta of iOS 15, so there is no way for us to know for sure who is going to be affected by the upgrade message. We are doing everything we can now in the aftermath to help our older customers, but it was not possible for us to proactively deal with what is happening here.

When uninstalling the old mSecure app, all of the data is deleted with it. In the case, the only way to retrieve it is using a backup or, after reinstalling the older version from the App Store App's Purchased list, you can try setting up either iCloud or Dropbox syncing if you were using one of the sync features before the message was displayed.

@Eleanor I thought you said you were able to get mSecure 4 reinstalled from the App Store and that it's working now? Did I misunderstand your last message? If you can open mSecure 4, do so now and tap the gear icon at the bottom of the app. In the Settings, scroll down and tap About mSecure. What version number do you see?

Hi Mike! Yes! Everything is working. The old version is 4.5.6 and I am now able to open it. I have also downloaded mSecure 5 and imported all my data, so both versions are working now. Thanks so much!

Great news @Eleanor...thank you for the clarification!

I'm very disappointed with what is happening. I have all my data with mSecure 4 and with the update I can't open the app (app needs to be updated). I tried going to mSecure5 but it requires my account password with msecure 4 and I don't have that either because I use fingerprint recognition. One cannot reset the password. I have older apps and the developers just needed to provide a new update in the app store. Why is this not possible for mSecure? 

@Mike, I don't know who the other Eleanor is but apparently there are now two Eleanor's in this thread. What fun. So for this Eleanor (I should have called myself EleanorG), I do NOT have mSecure5 and my data is not all imported and both versions are NOT working. I have been able to download mSecure v 4.5.1. When I download and set up v5 it does not trigger the data transfer. I was asking if I needed to first update to v4.5.5. Or what would you recommend? 

@EleanorG Sorry for the confusion that's happening here! This hasn't happened to me before, so I wasn't even aware to look for two people with the same name. Now that I know, I'll be able to keep things straight. If you are running a version of mSecure 4 that is older than v4.5.4, then that is going to cause the problem where the migration won't be triggered. Let's check on the version real quick just to be sure.

1) Open the Settings app on the device on which the migration did not take place when setting up your mSecure 5 account

2) Tap General

3) Tap iPhone Storage

4) Tap the magnifying glass in the top right, and type in "mSecure"

5) You should see two apps returned in the search, and you'll need you to tap the one with the bright blue icon, which is the older version of mSecure

In the "mSecure" screen, what version is displayed under the name of the app? It would be most helpful if you could send a screenshot of the "mSecure" screen with the version information.

Thanks @Mike, here’s a screen shot. I deleted v 5 when it wouldn’t work, so only have the old version on my phone

@EleanorG This confirms an older version of mSecure 4 is installed, and that's why the migration isn't taking place. Go ahead and email us at, and add "Attention Mike: No Migration" to the subject line. After you send the email, let me know here in the forum, and I'll respond as soon as I see the email.

Connexion ou Inscription pour poster un commentaire