Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!

Soporte mSecure

Date bug?


On the Windows app, when I use the Birthday template and insert the date / save, the date doesn't save and it goes blank. I'm not sure if this is a general date bug for other templates as well as I haven't tried it, but thought I'd put it out there.

When I use the iOS app, it works perfectly fine on there.

@Mike, I've attached the 2 snapshots on my Win11 laptop as requested.

region.jpg region.jpg
32.2 KB

Thank you for sending those screenshot @Ai. I just sent them over to our developer.

@Ai Our developer just tried to reproduce the date issue using your settings, but everything is working as it should no matter what settings he tries. You mentioned seeing something that let you to the conclusion you came to about what is happening. Is there anything that can be seen visually before you save the record and the date is lost? I think you were saying the month and day are getting switched around. Is it possible to take a screenshot of that before the record is saved to show him what's happening?

I have the same settings as @Ai when i try and save a record it switches the day and the month over when the record is saved, if they can be switched (day is less than 13) then it does otherwise it deletes the value. It does display correctly date in uk format when i pick the date from the calendar. I am running windows 11 if that makes a difference.

@Mike, I've attached 6 screenshots. The sample1 is where I've use the Date Picker (24/11/2016 - DD/MM/YYYY)) and it enters it correctly in Editor mode. As soon as I click the save (green tick) button, the date disappears as per screenshot2. The third screenshot shows it back in Editor mode and the date is not there anymore.

Like I said, I suspect as soon as I try saving it, it reverses the 24/11/2016 to 11/24/2016 which isn't a valid format. 

When I choose anything with a DD of less than 12 it works as shown in the sample2 screenshots. In Editor mode I pick a date of 12/04/2016, I save it and it saves as 04/12/2016.

Hope this helps you in the investigations.

@Ai Thank you for the screenshots and further information. The good news is, our developer has found some issues in our analytics that has helped him discovers some of the reasons why this is happening. I'll let him know what you showed me here, and hopefully by the end of the day he'll have a new build that can be downloaded. Would you be willing to download that build to confirm the issue is fixed or not?

@Mike, of course, no problems in testing that build. Just let me know what I need to do.

Thank you very much @Ai! The build is ready now, and all I need is the email address you use for the Store app on your PC. I feel like I have already asked you for this, but I'm not seeing your email address in any of the lists.

One more thing, if you don't want to write the email out here in the forum, go ahead and send an email with your Store account email address to Let me know when you send it, and I'll respond as soon as I see it.

@Mike, I've sent my e-mail address to the support e-mail, you should find it there.


I just replied to your email Ai. Thanks again for your help!

@Mike replied to you on e-mail:

I did the update and it went to v6.0.254.0 (not v6.0.255.0). I was still experiencing the same problem.


Is the fix in v6.0.255.0?

Just in case anyone is interested, tested the latest build:



Updated to Success!!!!!


I was able to insert Birthday Dates such as 25/10/15 and it correctly saved in the right format!


As an aside, I also had a look at the credit card template dates where it uses the scroll wheel for MM/YYYY and I can see the whole YYYY field now where before I could only see YY.


2 bugs quashed!!!! Fantastic, thank you so much!

Thank you for confirming this Ai! We're now in the process of getting two other problems worked out before the next release. We're hoping to get the build submitted before the end of the week, then this and some other issues will be resolved.

Iniciar sesión o Registrarse para publicar un comentario