Chat support available. Click the chat icon on the bottom right corner to start chatting with us right away!


Cursor in Search Field

 I think version 5 used to do this and I wondered if this feature is possible in version 6. When I log in and enter my mSecure pass (desktop app: windows and mac), the cursor used to go right to the search field so I could start typing my search as soon as the app fully opens to get to the pass I want. Now I have to grab my mouse and click into that field, taking my hands off the keyboard. It's a really little thing, but saves a few seconds each time I pull up the app. I really noticed when it was gone.

4 Personen gefällt die Idee

@Scott, glad I read this string otherwise I would have posted a duplicated.

@Mike, would heartedly ask the request. Please could you have the cursor focus immediately in the search box when opening the mSecure app on the desktop (Windows) version. It may seem like only saving 1 click, but after opening it numerous times through the day its one less tedious thing to do. Thanks!


I also use the windows desktop app almost continuously throughout the day and have noticed the cursor not defaulting to the search box in version 6.  Please put this on your list of needed improvements.

Hi Everyone,

As is usually the case, it's not so easy for me to reproduce what you all are reporting. I just ran into this a few minutes ago with another issue @Ai reported where the date for a Birthday record isn't getting saved. On my PC, every time mSecure locks, after I unlock it, the cursor is in the Search field. I'm sure you guys are reporting an actual problem, but I need to be able to reproduce it in order for our developer to fix it, and it should be a really simple fix if I can do that.

Do you have any other information that might help figure out that what might be different in your mSecure app as compared to mine? I tried closing and reopening, locking the app manually, and letting the app lock automatically when the search field was not in focus. Each time, after unlocking, the Search field was focussed. Is there something you are doing before the app locks that might make sense as to why the Search field isn't being focused after you unlock the app?


I am using Version of the Windows app.  When I initially launch the app and enter the password the app opens, but if I begin typing nothing happens because the search box is not selected.  Only after clicking the cursor on the search field can I begin a search.  If the search field is selected when the program locks, it remains selected when unlocking.  Thus, the problem for me is upon initial launch of the app.

In my particular situation, I can duplicate this each and every time on Windows and on Mac.

  1. Launch MSecure (Start->MSecure on Windows 11, Click MSecure in dock on MacOS 12.1)
  2. Program launches, cursor goes to password field
  3. Type in password, hit enter
  4. Opening animation plays, application goes into password list/view
  5. Without touching the mouse, start to type to try and search for a password, nothing happens because my cursor is not in the search field. On MacOS, it plays an error sound because I'm typing somewhere that cannot take text.
  6. I can move the mouse and click into the search field and it types/searches just fine.

That is so interesting...the same occurs for me Sam.  On my Windows app, if I leave the cursor in the search field, then close the program, and then launch the app again, the focus (cursor) will then appear in the search field.  I had not noticed that.

This behaviour does not occur on the Macbook app - Even if I leave the cursor in the search field when closing the app, on re-launch, the cursor does NOT appear in the search field.

Hi Everyone,

Ok, the good news is, upon fully closing and then reopening mSecure on my PC, the cursor is not in the search field. The weird thing is, I'm almost certain I tried doing that before and it worked, but it's good that it's not working now. However, if the app locks, no matter where the cursor was left, when unlocked, it is always in the search field. Can you all double-check this to see if it's working the same for you? On Windows, I think that the problem is the cursor is not in the search field when the app is opened after being closed.

Also, I checked on Mac, and it's functioning for me like it is for @Noella. The cursor is never in the search field, so I'll have the developer look into this.

@Mike, just to add my experience.

OS - Win10 AND Win11

mSecure version -

First time opening app - focus not set to anything, have to click into search bar to start typing

If in search bar and manually lock app - focus stays in search bar after going back in with previous information held

If in search bar and close app - focus not set to anything after opening up the app again and have to click into search bar to start typing

@Mike...yes this happens exactly as you indicated on my PC  "However, if the app locks, no matter where the cursor was left, when unlocked, it is always in the search field. Can you all double-check this to see if it's working the same for you?"


Windows App Version updated to running on Windows 10 Pro

I have the same experience as @Ai.

Thanks everyone! I'll write this up for both developers. I'm pretty sure each will fix the issue in the next release.

When you log in to the app, the first place I usually go is to enter something in the search box at the top of the screen.  It would be great if the curser is already sitting in the search box so all I have to do is start entering my search information. Currently, I first have to click in the search box before I can start typing. This slight change would make using the app much more efficient.  

@Mark This is on our radar and will be fixed in a future update. The cursor is supposed to start out in the search field every time the app is opened, but it's not doing that in the current release. That will be fixed in the upcoming release or the release after it.

Anmelden oder Registrieren um einen Kommentar zu veröffentlichen